summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEwoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>2010-08-06 16:37:07 +0200
committerEwoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>2010-08-06 16:37:07 +0200
commit307142bf24175b7348f7a5f8006e89f4cdf14470 (patch)
treed1eac7a17aa46488f2fcfd05f0f970e286bbf604
parentmv {www-apps,net-mail}/zarafa (diff)
downloaddagger-307142bf24175b7348f7a5f8006e89f4cdf14470.tar.gz
dagger-307142bf24175b7348f7a5f8006e89f4cdf14470.tar.bz2
dagger-307142bf24175b7348f7a5f8006e89f4cdf14470.zip
libvmime: Clean up patching code, repoman fixes
-rw-r--r--dev-cpp/libvmime/Manifest2
-rw-r--r--dev-cpp/libvmime/libvmime-0.7.1.ebuild29
2 files changed, 17 insertions, 14 deletions
diff --git a/dev-cpp/libvmime/Manifest b/dev-cpp/libvmime/Manifest
index 22bd310..fbf71b2 100644
--- a/dev-cpp/libvmime/Manifest
+++ b/dev-cpp/libvmime/Manifest
@@ -1,3 +1,3 @@
DIST libvmime-0.7.1.tar.bz2 418302 RMD160 259983c8844108c8040bcbae2ea53e453a811124 SHA1 30fefbdd31c2fa46976984f18d4d21bf3c2ec20a SHA256 fc3476aec565341594c7c4dca982539695b61ecb92a438f19860e9130ca019e3
DIST zarafa-vmime-patches.tar.gz 12326 RMD160 db7d53e7876208f8f6bd773c28350b834a56c0b4 SHA1 b85c3b6a25eb5d20429a5532c52b01e54549f7d2 SHA256 f6eacba0c8e7f33ee7b9a9acf9ea1b230d205c8da4710633e3c512d902e60d7d
-EBUILD libvmime-0.7.1.ebuild 1537 RMD160 387cd36fce7ece4b6bbd561318b5349f82b180a0 SHA1 273417ea1ac1330d6d79600cdf6a947cec534453 SHA256 f4b7a33126a81a07f809c837c1131073fbb53c7b38b83b6b061cbf56120bb504
+EBUILD libvmime-0.7.1.ebuild 1537 RMD160 142771d431d72244d06c2b2901468ca70a06a83a SHA1 6554e94d567af21d1540c72a53299cfda3458ad3 SHA256 b427a7d18238ff2ea2b11425f6fae7924e226d80d9b755130ab8b7039c91259c
diff --git a/dev-cpp/libvmime/libvmime-0.7.1.ebuild b/dev-cpp/libvmime/libvmime-0.7.1.ebuild
index 8c571bc..0191343 100644
--- a/dev-cpp/libvmime/libvmime-0.7.1.ebuild
+++ b/dev-cpp/libvmime/libvmime-0.7.1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
+
inherit eutils
ZARAFA_PATCHES="zarafa-vmime-patches.tar.gz"
@@ -9,7 +11,7 @@ ZARAFA_PATCHES="zarafa-vmime-patches.tar.gz"
DESCRIPTION="A powerful C++ class library for working with MIME messages and services like IMAP, POP or SMTP."
HOMEPAGE="http://www.vmime.org/"
SRC_URI="mirror://sourceforge/vmime/${P}.tar.bz2
- http://developer.zarafa.com/download/${ZARAFA_PATCHES}"
+ http://developer.zarafa.com/download/${ZARAFA_PATCHES}"
LICENSE="GPL-2"
SLOT="0"
@@ -17,25 +19,21 @@ KEYWORDS="~x86 ~amd64"
IUSE="debug doc examples sasl ssl"
RDEPEND="sasl? ( net-libs/libgsasl )
- ssl? ( net-libs/gnutls )
- virtual/libiconv"
+ ssl? ( net-libs/gnutls )
+ virtual/libiconv"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX="diff" EPATCH_SOURCE="${WORKDIR}" epatch
-src_unpack() {
- unpack ${A}
- mv *.diff ${S}
- cd "${S}"
- for x in *.diff; do
- epatch "${x}";
- done
sed -i \
-e "s|doc/\${PACKAGE_TARNAME}|doc/${PF}|" \
-e "s|doc/\$(GENERIC_LIBRARY_NAME)|doc/${PF}|" \
configure Makefile.in || die "sed failed"
}
-src_compile() {
+src_configure() {
econf \
$(use_enable debug) \
$(use_enable sasl) \
@@ -47,7 +45,11 @@ src_compile() {
--enable-messaging-proto-imap \
--enable-messaging-proto-maildir \
--enable-messaging-proto-sendmail
+}
+
+src_compile() {
emake || die "emake failed"
+
if use doc ; then
doxygen vmime.doxygen || die "doxygen failed"
fi
@@ -55,6 +57,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+
if use doc ; then
dohtml doc/html/*
fi