summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cowdancer/cowdancer-0.13.ebuild')
-rw-r--r--app-misc/cowdancer/cowdancer-0.13.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/cowdancer/cowdancer-0.13.ebuild b/app-misc/cowdancer/cowdancer-0.13.ebuild
new file mode 100644
index 0000000..7567026
--- /dev/null
+++ b/app-misc/cowdancer/cowdancer-0.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Cowdancer allows copy-on-write file access, based on hardlinks."
+HOMEPAGE="http://www.netfort.gr.jp/~dancer/software/cowdancer.html"
+
+MY_P=${P//-/_}
+SRC_URI="http://www.netfort.gr.jp/~dancer/software/downloads/${MY_P}.tar.gz"
+LICENSE=""
+
+# The tests require the libraries and binaries in a specific location due to
+# LD_PRELOADing. Perhaps we should look at the sandbox tests.
+RESTRICT="test"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/patches/${PV}.make_install.patch" || die "Failed to apply patches."
+}