summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-03-25 15:10:37 +0100
committerAgostino Sarubbo <ago@gentoo.org>2022-03-25 15:10:37 +0100
commit85334ab035e3e3e4805a0f1d5a165f481f493965 (patch)
treefb33106e552b893b685f251ee302ab3d90da4054 /app-metrics/uniloader/uniloader-22.02.1.ebuild
parentapp-metrics/queuemetrics: version bump to 22.02.7.164 - remove old. (diff)
downloadago-85334ab035e3e3e4805a0f1d5a165f481f493965.tar.gz
ago-85334ab035e3e3e4805a0f1d5a165f481f493965.tar.bz2
ago-85334ab035e3e3e4805a0f1d5a165f481f493965.zip
app-metrics/uniloader: version bump to 22.02.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-metrics/uniloader/uniloader-22.02.1.ebuild')
-rw-r--r--app-metrics/uniloader/uniloader-22.02.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-metrics/uniloader/uniloader-22.02.1.ebuild b/app-metrics/uniloader/uniloader-22.02.1.ebuild
new file mode 100644
index 0000000..7d62851
--- /dev/null
+++ b/app-metrics/uniloader/uniloader-22.02.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# DISCLAIMER:
+# This ebuild does NOT follow the Gentoo QA Rules, instead it follows the upstream way to install and run the application
+
+EAPI=7
+
+DESCRIPTION="A go-based program that uploads data to a local or remote QueueMetrics"
+HOMEPAGE="https://www.queuemetrics-live.com/uniloader.jsp"
+LICENSE="all-rights-reserved"
+SRC_URI="https://downloads.loway.ch/software/${PN}/${P}.tar.gz"
+RESTRICT="mirror"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="acct-group/queuemetrics
+ acct-user/queuemetrics"
+
+src_install() {
+ dodir /opt/${PN}/bin
+ exeinto /opt/${PN}/bin
+ newexe bin/${PN}_amd64 ${PN}
+
+ keepdir /var/log/${PN}
+ fowners queuemetrics:queuemetrics /var/log/${PN}
+ fperms 0750 /var/log/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}