summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-proto/xcb-proto/xcb-proto-1.8-r2.ebuild')
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.8-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-proto/xcb-proto/xcb-proto-1.8-r2.ebuild b/x11-proto/xcb-proto/xcb-proto-1.8-r2.ebuild
new file mode 100644
index 000000000000..e1a85ae4b5fb
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.8-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.8-r2.ebuild,v 1.1 2013/03/23 18:45:54 pacho Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+XORG_MULTILIB=yes
+inherit python-single-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ xorg-2_pkg_setup
+}
+
+pkg_postinst() {
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}