summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/icewoed/icewoed-1.8.ebuild')
-rw-r--r--x11-misc/icewoed/icewoed-1.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/icewoed/icewoed-1.8.ebuild b/x11-misc/icewoed/icewoed-1.8.ebuild
new file mode 100644
index 000000000000..3839bb703483
--- /dev/null
+++ b/x11-misc/icewoed/icewoed-1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewoed/icewoed-1.8.ebuild,v 1.1 2004/08/27 07:47:50 phosphan Exp $
+
+DESCRIPTION="IceWM winoptions editor."
+SRC_URI="mirror://sourceforge/icecc/${P}.tar.bz2"
+HOMEPAGE="http://icecc.sourceforge.net/"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3.0.0"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ sed -e 's:/usr/local:/usr:' -i ${PN}.pro || die 'sed failed'
+ echo >> ${PN}.pro -e "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}\nQMAKE_CFLAGS_RELEASE += ${CFLAGS}"
+}
+
+src_compile () {
+ qmake || die
+}
+
+src_install () {
+ make INSTALL_ROOT="${D}" install || die
+ dodoc AUTHORS README TODO ChangeLog
+}