summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/qt-3.3.0.ebuild15
2 files changed, 11 insertions, 10 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index d0182a4d50a5..a47f6322bd23 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.122 2004/02/13 13:05:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.123 2004/02/14 15:44:00 caleb Exp $
+
+ 14 Feb 2004; Caleb Tennis <caleb@gentoo.org> qt-3.3.0.ebuild:
+ Change back to the way it was with -libdir settings. I'll figure out a way
+ around the other bug a little later.
13 Feb 2004; Caleb Tennis <caleb@gentoo.org> qt-3.3.0.ebuild:
Recomment out directory setting lines so that a Qt upgrade links properly
diff --git a/x11-libs/qt/qt-3.3.0.ebuild b/x11-libs/qt/qt-3.3.0.ebuild
index 9034030412ab..9915e0c27959 100644
--- a/x11-libs/qt/qt-3.3.0.ebuild
+++ b/x11-libs/qt/qt-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.0.ebuild,v 1.16 2004/02/13 13:05:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.0.ebuild,v 1.17 2004/02/14 15:44:00 caleb Exp $
SRCTYPE="free"
DESCRIPTION="QT version ${PV}"
@@ -31,6 +31,7 @@ DEPEND="virtual/x11 virtual/xft
RDEPEND="${DEPEND}"
S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
+LD_LIBRARY_PATH=${S}/lib:${LD_LIBRARY_PATH}
QTBASE=/usr/qt/3
export QTDIR=${S}
@@ -81,14 +82,9 @@ src_compile() {
-system-libpng -lpthread -xft -platform ${PLATFORM} -xplatform \
${PLATFORM} -xrender -prefix ${D}${QTBASE} -plugindir ${QTBASE}/plugins \
-docdir ${QTBASE}/doc -translationdir ${QTBASE}/translations \
- -datadir ${QTBASE} -sysconfdir ${QTBASE}/etc/settings -fast ${myconf} || die
-# -libdir ${QTBASE}/lib -headerdir ${QTBASE}/include \
-# -bindir ${QTBASE}/bin -dlopen-opengl || die
-#
-# The above lines should be commented out. It's more appropriate to set them, but
-# the problem is that the tools built during Qt's compilation (like uic) will
-# use the already installed Qt's installation instead of the newly installing
-# Qt's, which may be binary incompatible and cause build problems.
+ -datadir ${QTBASE} -sysconfdir ${QTBASE}/etc/settings -fast ${myconf} \
+ -libdir ${QTBASE}/lib -headerdir ${QTBASE}/include \
+ -bindir ${QTBASE}/bin -dlopen-opengl || die
export QTDIR=${S}
emake src-qmake src-moc sub-src sub-tools || die
@@ -104,6 +100,7 @@ src_install() {
dobin bin/*
# libraries
+
dolib lib/libqt-mt.so.3.3.0 lib/libqui.so.1.0.0
dolib lib/lib{editor,qassistantclient,designercore}.a lib/libqt-mt.la