summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r11.ebuild15
-rw-r--r--x11-libs/openmotif/openmotif-2.2.3-r5.ebuild15
3 files changed, 29 insertions, 7 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 87bcc2606442..7395e2182b50 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.99 2005/03/08 15:42:14 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.100 2005/03/10 14:26:55 lanius Exp $
+
+ 10 Mar 2005; Heinrich Wendel <lanius@gentoo.org>
+ openmotif-2.1.30-r11.ebuild, openmotif-2.2.3-r5.ebuild:
+ don't remove motif-config profile on upgrade
08 Mar 2005; Heinrich Wendel <lanius@gentoo.org>
-openmotif-2.1.30-r4.ebuild, -openmotif-2.1.30-r5.ebuild,
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r11.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r11.ebuild
index 5da9a48874c3..084165682bcd 100644
--- a/x11-libs/openmotif/openmotif-2.1.30-r11.ebuild
+++ b/x11-libs/openmotif/openmotif-2.1.30-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r11.ebuild,v 1.3 2005/03/07 19:48:19 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r11.ebuild,v 1.4 2005/03/10 14:26:55 lanius Exp $
inherit eutils flag-o-matic multilib
@@ -160,6 +160,15 @@ pkg_postinst() {
motif-config --install openmotif-2.1
}
-pkg_prerm() {
- motif-config --uninstall openmotif-2.1
+is_upgrade() {
+ vdb_path=`portageq vdb_path`
+ if [ "`grep -r SLOT $vdb_path/${CATEGORY}/${PN}* | grep $SLOT`" ]; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+pkg_postrm() {
+ is_upgrade || motif-config --uninstall openmotif-2.1
}
diff --git a/x11-libs/openmotif/openmotif-2.2.3-r5.ebuild b/x11-libs/openmotif/openmotif-2.2.3-r5.ebuild
index 48863390b0ee..7d5c2e6dbcfa 100644
--- a/x11-libs/openmotif/openmotif-2.2.3-r5.ebuild
+++ b/x11-libs/openmotif/openmotif-2.2.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3-r5.ebuild,v 1.3 2005/03/07 19:48:19 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3-r5.ebuild,v 1.4 2005/03/10 14:26:55 lanius Exp $
inherit eutils libtool flag-o-matic multilib
@@ -133,6 +133,15 @@ pkg_postinst() {
motif-config --install openmotif-2.2
}
-pkg_prerm() {
- motif-config --uninstall openmotif-2.2
+is_upgrade() {
+ vdb_path=`portageq vdb_path`
+ if [ "`grep -r SLOT $vdb_path/${CATEGORY}/${PN}* | grep $SLOT`" ]; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+pkg_postrm() {
+ is_upgrade || motif-config --uninstall openmotif-2.2
}