summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog11
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch11
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.5.1-cmakelists.patch (renamed from www-plugins/lightspark/files/lightspark-0.4.4.3-cmakelists.patch)14
-rw-r--r--www-plugins/lightspark/lightspark-0.4.5.1.ebuild (renamed from www-plugins/lightspark/lightspark-0.4.5.ebuild)11
4 files changed, 22 insertions, 25 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 8e69f8ea46ad..65b24bea514c 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.21 2010/12/12 21:21:38 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.22 2010/12/21 14:53:47 chithanh Exp $
+
+*lightspark-0.4.5.1 (21 Dec 2010)
+
+ 21 Dec 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -files/lightspark-0.4.4.3-cmakelists.patch, -lightspark-0.4.5.ebuild,
+ +lightspark-0.4.5.1.ebuild,
+ -files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch,
+ +files/lightspark-0.4.5.1-cmakelists.patch:
+ Version bump, bug #349093
12 Dec 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
lightspark-0.4.5.ebuild, +files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch:
diff --git a/www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch b/www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch
deleted file mode 100644
index 3882a0ae226a..000000000000
--- a/www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur a/scripting/abc.h b/scripting/abc.h
---- a/scripting/abc.h 2010-12-08 17:55:46.000000000 +0100
-+++ b/scripting/abc.h 2010-12-12 21:49:56.549000030 +0100
-@@ -19,6 +19,7 @@
-
- #ifndef _ABC_H
- #define _ABC_H
-+#define alignof _alignof
-
- #include "compat.h"
- #include <llvm/Module.h>
diff --git a/www-plugins/lightspark/files/lightspark-0.4.4.3-cmakelists.patch b/www-plugins/lightspark/files/lightspark-0.4.5.1-cmakelists.patch
index 4921ecb402a1..362787a4ac0f 100644
--- a/www-plugins/lightspark/files/lightspark-0.4.4.3-cmakelists.patch
+++ b/www-plugins/lightspark/files/lightspark-0.4.5.1-cmakelists.patch
@@ -1,16 +1,16 @@
diff -ur a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2010-09-24 19:17:38.000000000 +0200
-+++ b/CMakeLists.txt 2010-10-18 17:57:45.168022354 +0200
-@@ -321,7 +321,7 @@
+--- a/CMakeLists.txt 2010-12-16 06:28:01.000000000 +0100
++++ b/CMakeLists.txt 2010-12-21 14:59:17.500027007 +0100
+@@ -332,7 +332,7 @@
${Boost_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY}
${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${FREETYPE_LIBRARIES}
${OPENGL_LIBRARIES} ${FTGL_LIBRARIES} ${GLEW_LIBRARIES} ${PCRECPP_LIBRARIES}
-- ${Threads_LIBRARIES} ${XMLPP_LIBRARIES})
-+ ${Threads_LIBRARIES} ${XMLPP_LIBRARIES} ${CMAKE_MODULE_LINKER_FLAGS})
+- ${Threads_LIBRARIES} ${XMLPP_LIBRARIES} ${CMAKE_DL_LIBS})
++ ${Threads_LIBRARIES} ${XMLPP_LIBRARIES} ${CMAKE_DL_LIBS} ${CMAKE_MODULE_LINKER_FLAGS})
SET_TARGET_PROPERTIES(spark PROPERTIES VERSION "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}")
SET_TARGET_PROPERTIES(spark PROPERTIES SOVERSION "${MAJOR_VERSION}.${MINOR_VERSION}")
-@@ -333,7 +333,7 @@
+@@ -344,7 +344,7 @@
IF(COMPILE_LIGHTSPARK)
ADD_EXECUTABLE(lightspark main.cpp)
TARGET_LINK_LIBRARIES(lightspark spark)
@@ -19,7 +19,7 @@ diff -ur a/CMakeLists.txt b/CMakeLists.txt
IF(UNIX)
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lightspark.frag DESTINATION ${DATADIR}/lightspark)
-@@ -347,7 +347,7 @@
+@@ -359,7 +359,7 @@
IF(COMPILE_TIGHTSPARK)
ADD_EXECUTABLE(tightspark tightspark.cpp)
TARGET_LINK_LIBRARIES(tightspark spark)
diff --git a/www-plugins/lightspark/lightspark-0.4.5.ebuild b/www-plugins/lightspark/lightspark-0.4.5.1.ebuild
index 450382a49eca..593efa97ebe0 100644
--- a/www-plugins/lightspark/lightspark-0.4.5.ebuild
+++ b/www-plugins/lightspark/lightspark-0.4.5.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.5.ebuild,v 1.2 2010/12/12 21:21:38 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.5.1.ebuild,v 1.1 2010/12/21 14:53:47 chithanh Exp $
EAPI=3
-inherit cmake-utils nsplugins multilib
+inherit cmake-utils nsplugins multilib versionator
DESCRIPTION="High performance flash player"
HOMEPAGE="https://launchpad.net/lightspark/"
-SRC_URI="http://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.gz"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PN}-$(get_version_component_range 1-3)/+download/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
@@ -27,7 +27,7 @@ RDEPEND="dev-cpp/libxmlpp:2.6
)
net-misc/curl
>=sys-devel/gcc-4.4
- >=sys-devel/llvm-2.7
+ >=sys-devel/llvm-2.8-r2
virtual/opengl
nsplugin? (
dev-libs/nspr
@@ -43,9 +43,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
PATCHES=(
- "${FILESDIR}"/${PN}-0.4.4.3-cmakelists.patch
+ "${FILESDIR}"/${PN}-0.4.5.1-cmakelists.patch
"${FILESDIR}"/${PN}-0.4.5-allow-disabling-pulseaudio.patch
- "${FILESDIR}"/${PN}-0.4.5-llvm-2.8-gcc-4.5.patch
)
src_configure() {