summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitweb/ChangeLog7
-rw-r--r--www-apps/gitweb/files/digest-gitweb-1.5.03
-rw-r--r--www-apps/gitweb/gitweb-1.5.0.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/www-apps/gitweb/ChangeLog b/www-apps/gitweb/ChangeLog
index 4b20fc707f60..17c550b74830 100644
--- a/www-apps/gitweb/ChangeLog
+++ b/www-apps/gitweb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gitweb
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.19 2007/01/12 19:46:59 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.20 2007/02/15 18:39:39 ferdy Exp $
+
+*gitweb-1.5.0 (15 Feb 2007)
+
+ 15 Feb 2007; Fernando J. Pereda <ferdy@gentoo.org> +gitweb-1.5.0.ebuild:
+ New upstream version
12 Jan 2007; Fernando J. Pereda <ferdy@gentoo.org> files/apache.htaccess:
Fix apache.htaccess as per bug #161073. Thanks to Ira Snyder
diff --git a/www-apps/gitweb/files/digest-gitweb-1.5.0 b/www-apps/gitweb/files/digest-gitweb-1.5.0
new file mode 100644
index 000000000000..1ae71cbf1d8b
--- /dev/null
+++ b/www-apps/gitweb/files/digest-gitweb-1.5.0
@@ -0,0 +1,3 @@
+MD5 5c3e163ac201695c9bfd5a19d730303c git-1.5.0.tar.bz2 1041253
+RMD160 2ff7a1d31a73e1a75ccd284d8e7c35e05268ec73 git-1.5.0.tar.bz2 1041253
+SHA256 98dc8ac7b1db00dd414349c46cce3cc1d8f7f6aa7dbe3c3ab237b937bf032b9d git-1.5.0.tar.bz2 1041253
diff --git a/www-apps/gitweb/gitweb-1.5.0.ebuild b/www-apps/gitweb/gitweb-1.5.0.ebuild
new file mode 100644
index 000000000000..ef6110cd44b4
--- /dev/null
+++ b/www-apps/gitweb/gitweb-1.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/gitweb-1.5.0.ebuild,v 1.1 2007/02/15 18:39:39 ferdy Exp $
+
+inherit webapp
+
+GIT_VERSION="${PV}"
+
+DESCRIPTION="Web interface to GIT repositories"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+>=dev-util/git-${PV}"
+
+S="${WORKDIR}"/git-${GIT_VERSION}/gitweb
+
+src_compile() {
+ sed -i \
+ -e 's~^\(GITWEB_PROJECTROOT =\).*$~\1 /var/git~g' \
+ -e 's~^\(GITWEB_SITE_HEADER =\).*$~\1 header.html~g' \
+ -e 's~^\(GITWEB_SITE_FOOTER =\).*$~\1 footer.html~g' \
+ ../Makefile || die "failed to sed Makefile"
+ emake -C .. prefix=/usr gitweb/gitweb.cgi || die "emake failed"
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc README "${FILESDIR}"/README.gentoo
+ rm -f README
+
+ cp gitweb.{cgi,css} git-{favicon,logo}.png "${D}/${MY_HTDOCSDIR}"
+ cp "${FILESDIR}"/apache.htaccess "${D}/${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}