summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/pam/pam-0.75-r8.ebuild')
-rw-r--r--sys-libs/pam/pam-0.75-r8.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/pam/pam-0.75-r8.ebuild b/sys-libs/pam/pam-0.75-r8.ebuild
index fe6d1e47e5d6..2c3f1efb234d 100644
--- a/sys-libs/pam/pam-0.75-r8.ebuild
+++ b/sys-libs/pam/pam-0.75-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r8.ebuild,v 1.14 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r8.ebuild,v 1.15 2004/06/28 02:22:20 agriffis Exp $
IUSE="berkdb"
@@ -91,7 +91,7 @@ src_compile() {
rm -f Make.Rules.orig
fi
- if [ -z "$(use berkdb)" ]
+ if ! use berkdb
then
cp Make.Rules Make.Rules.orig
sed -e "s:^HAVE_LIBNDBM=yes:HAVE_LIBNDBM=no:" \
@@ -116,7 +116,7 @@ src_install() {
then
if ! ls -1 ${D}/lib/security/$(basename ${x})*.so &> /dev/null
then
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
continue
fi