summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild
index 2507c3501880..910fea85d702 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild,v 1.7 2009/07/18 20:18:30 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild,v 1.8 2009/12/07 23:01:46 vapier Exp $
inherit toolchain-funcs
@@ -23,12 +23,13 @@ src_unpack() {
cd "${S}"
sed -i \
-e 's:-O2:$(CFLAGS):' \
- -e 's:$(CC):$(CC) $(LDFLAGS):' \
+ -e '/-lz/s:$: $(LDFLAGS):' \
Makefile || die "sed failed"
+ sed -i -e 's:get_nprocs():sysconf(_SC_NPROCESSORS_ONLN):' *.c
}
src_compile() {
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die
+ emake CC="$(tc-getCC)" || die
}
src_install() {