summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ext3grep/ext3grep-0.10.2.ebuild')
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.2.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
index 04293ffeaee0..9a6dc3f180fa 100644
--- a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
+++ b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.2.ebuild,v 1.3 2012/02/26 17:51:44 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.2.ebuild,v 1.4 2012/11/03 10:03:44 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit eutils
DESCRIPTION="Recover deleted files on an ext3 file system"
@@ -14,8 +14,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug pch"
+DOCS="NEWS README"
+
+RDEPEND=""
+DEPEND="sys-fs/e2fsprogs
+ virtual/os-headers
+ virtual/pkgconfig"
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10.1-gcc44.patch
+ epatch \
+ "${FILESDIR}"/${PN}-0.10.1-gcc44.patch \
+ "${FILESDIR}"/${P}-include-unistd_h-for-sysconf.patch
# Fix build against latest e2fsprogs, taken from
# https://code.google.com/p/ext3grep/issues/detail?id=34
@@ -24,12 +33,6 @@ src_prepare() {
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable debug) \
$(use_enable pch)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc NEWS README || die
-}