summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-4.8.1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.8.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-4.8.1.ebuild b/sys-devel/gcc/gcc-4.8.1.ebuild
index b382eb3e101d..6b33483621b3 100644
--- a/sys-devel/gcc/gcc-4.8.1.ebuild
+++ b/sys-devel/gcc/gcc-4.8.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.1.ebuild,v 1.2 2013/08/27 04:48:17 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.1.ebuild,v 1.3 2013/08/31 11:45:41 zorry Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
# Hardened gcc 4 stuff
-PIE_VER="0.5.6"
+PIE_VER="0.5.7"
SPECS_VER="0.2.0"
SPECS_GCC_VER="4.4.3"
# arch/libc configurations known to be stable with {PIE,SSP}-by-default
@@ -45,8 +45,8 @@ src_unpack() {
toolchain_src_unpack
use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+ #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
}
pkg_setup() {