summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-apple')
-rw-r--r--sys-devel/binutils-apple/ChangeLog6
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.1.ebuild13
2 files changed, 14 insertions, 5 deletions
diff --git a/sys-devel/binutils-apple/ChangeLog b/sys-devel/binutils-apple/ChangeLog
index b6015213dba2..34869d0df05a 100644
--- a/sys-devel/binutils-apple/ChangeLog
+++ b/sys-devel/binutils-apple/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/binutils-apple
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.19 2011/09/21 20:41:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.20 2011/09/25 08:03:35 grobian Exp $
+
+ 25 Sep 2011; Fabian Groffen <grobian@gentoo.org> binutils-apple-4.1.ebuild:
+ Stop compiling unused libunwind, mimic Availability.h macros for pre OS X
+ Lion hosts
21 Sep 2011; Fabian Groffen <grobian@gentoo.org> binutils-apple-4.1.ebuild:
Add keywords for 4.1, since it seems to work fine
diff --git a/sys-devel/binutils-apple/binutils-apple-4.1.ebuild b/sys-devel/binutils-apple/binutils-apple-4.1.ebuild
index 92b3e104170c..51fcdace491b 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.1.ebuild,v 1.2 2011/09/21 20:41:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.1.ebuild,v 1.3 2011/09/25 08:03:35 grobian Exp $
EAPI="3"
@@ -73,10 +73,15 @@ src_prepare() {
mkdir -p include/llvm-c || die
cp "${WORKDIR}"/ld64-unwind/ld64-97.14-llvm-lto.h include/llvm-c/lto.h || die
# make libunwind sources known
- #pushd "${WORKDIR}"/libunwind/include > /dev/null
ln -s ../../${LIBUNWIND}/src libunwind || die
cp ../../${LIBUNWIND}/include/*.h include/ || die
- #popd > /dev/null
+ # mimic OS X Lion-style Availability.h macros
+ if [[ ${CHOST#*-darwin} -le 10 ]] ; then
+ {
+ echo "#define __OSX_AVAILABLE_STARTING(x,y) "
+ echo "#define __OSX_AVAILABLE_BUT_DEPRECATED(a,b,c,d) "
+ } > include/Availability.h
+ fi
echo '' > configure.h
echo '' > linker_opts
@@ -157,6 +162,7 @@ src_configure() {
}
compile_libunwind() {
+ # not used, just for testing, and possible use in the future
einfo "building ${LIBUNWIND}"
cd "${S}"/${LIBUNWIND}/src
emake DYLDINCS=-I../../${DYLD}/include || die
@@ -197,7 +203,6 @@ compile_cctools() {
}
src_compile() {
- compile_libunwind
compile_ld64
compile_cctools
}