summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild')
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild
new file mode 100644
index 000000000000..63ae9776b7af
--- /dev/null
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild,v 1.1 2010/10/03 17:57:24 josejx Exp $
+
+inherit eutils
+
+DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
+### Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe
+
+HOMEPAGE="http://penguinppc.org/projects/yaboot/"
+SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc64"
+IUSE="ibm"
+DEPEND="!sys-boot/yaboot
+ sys-apps/powerpc-utils"
+RDEPEND="!ibm? ( sys-fs/hfsutils
+ sys-fs/hfsplusutils
+ sys-fs/mac-fdisk )"
+PROVIDE="virtual/bootloader"
+
+src_install() {
+ cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
+}