summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/systemd-198.ebuild')
-rw-r--r--sys-apps/systemd/systemd-198.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-198.ebuild b/sys-apps/systemd/systemd-198.ebuild
index f13472965449..8c41a4afcd93 100644
--- a/sys-apps/systemd/systemd-198.ebuild
+++ b/sys-apps/systemd/systemd-198.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-198.ebuild,v 1.4 2013/03/10 15:14:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-198.ebuild,v 1.5 2013/03/10 16:45:46 floppym Exp $
EAPI=5
@@ -188,6 +188,10 @@ optfeature() {
pkg_postinst() {
enewgroup systemd-journal
+ if use http; then
+ enewgroup systemd-journal-gateway
+ enewuser systemd-journal-gateway -1 -1 -1 systemd-journal-gateway
+ fi
systemd_update_catalog
mkdir -p "${ROOT}"/run || ewarn "Unable to mkdir /run, this could mean trouble."