summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/ChangeLog6
-rw-r--r--sys-apps/openrc/openrc-0.9.4.ebuild6
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index 7b2d3b6baba6..09ac91f96018 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.174 2011/11/18 18:25:24 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.175 2011/11/21 03:11:18 vapier Exp $
+
+ 21 Nov 2011; Mike Frysinger <vapier@gentoo.org> openrc-0.9.4.ebuild,
+ openrc-9999.ebuild:
+ Trim old baselayout-1 dirs in /lib/.
18 Nov 2011; William Hubbs <williamh@gentoo.org> openrc-9999.ebuild:
Add static-libs use flag for bug #378267
diff --git a/sys-apps/openrc/openrc-0.9.4.ebuild b/sys-apps/openrc/openrc-0.9.4.ebuild
index 1e618ca4e9f4..4275d3ab2b1f 100644
--- a/sys-apps/openrc/openrc-0.9.4.ebuild
+++ b/sys-apps/openrc/openrc-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.9.4.ebuild,v 1.2 2011/11/07 12:57:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.9.4.ebuild,v 1.3 2011/11/21 03:11:18 vapier Exp $
EAPI=4
@@ -419,6 +419,10 @@ pkg_postinst() {
# update the dependency tree after touching all files #224171
[[ "${ROOT}" = "/" ]] && "${ROOT}/${LIBDIR}"/rc/bin/rc-depend -u
+ # baselayout leaves behind a lot of .keep files, so let's clean them up
+ find "${ROOT}"/lib*/rcscripts/ -name .keep -exec rm -f {} +
+ find "${ROOT}"/lib*/rcscripts/ -depth -type d -exec rmdir {} + 2>/dev/null
+
elog "You should now update all files in /etc, using etc-update"
elog "or equivalent before restarting any services or this host."
elog
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index e5cf5e4e91f0..ca97c8b5ff39 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.90 2011/11/18 18:25:24 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.91 2011/11/21 03:11:18 vapier Exp $
EAPI=4
@@ -415,6 +415,10 @@ pkg_postinst() {
# update the dependency tree after touching all files #224171
[[ "${ROOT}" = "/" ]] && "${ROOT}/${LIBDIR}"/rc/bin/rc-depend -u
+ # baselayout leaves behind a lot of .keep files, so let's clean them up
+ find "${ROOT}"/lib*/rcscripts/ -name .keep -exec rm -f {} +
+ find "${ROOT}"/lib*/rcscripts/ -depth -type d -exec rmdir {} + 2>/dev/null
+
elog "You should now update all files in /etc, using etc-update"
elog "or equivalent before restarting any services or this host."
elog