summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/groff/groff-1.19.2-r2.ebuild')
-rw-r--r--sys-apps/groff/groff-1.19.2-r2.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/groff/groff-1.19.2-r2.ebuild b/sys-apps/groff/groff-1.19.2-r2.ebuild
new file mode 100644
index 000000000000..3d4b061b22b0
--- /dev/null
+++ b/sys-apps/groff/groff-1.19.2-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.2-r2.ebuild,v 1.1 2008/02/24 18:59:32 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib autotools
+
+DESCRIPTION="Text formatter used for man pages"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+SRC_URI="mirror://gnu/groff/${P}.tar.gz
+ cjk? ( mirror://gentoo/groff-1.19.2-japanese.patch.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk X"
+
+DEPEND=">=sys-apps/texinfo-4.7-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch "${FILESDIR}"/${P}-infoext.patch
+
+ epatch "${FILESDIR}"/${P}-man-unicode-dashes.patch #16108 #17580 #121502
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+
+ # Make sure we can cross-compile this puppy
+ if tc-is-cross-compiler ; then
+ sed -i \
+ -e '/^GROFFBIN=/s:=.*:=/usr/bin/groff:' \
+ -e '/^TROFFBIN=/s:=.*:=/usr/bin/troff:' \
+ -e '/^GROFF_BIN_PATH=/s:=.*:=:' \
+ contrib/mom/Makefile.sub \
+ doc/Makefile.in \
+ doc/Makefile.sub || die "cross-compile sed failed"
+ fi
+
+ if use cjk ; then
+ epatch "${WORKDIR}"/groff-1.19.2-japanese.patch #134377
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+ tc-export CC CXX
+
+ # -Os causes segfaults, -O is probably a fine replacement
+ # (fixes bug 36008, 06 Jan 2004 agriffis)
+ replace-flags -Os -O
+
+ econf \
+ --with-appresdir=/etc/X11/app-defaults \
+ $(use_with X x) \
+ $(use_enable cjk japanese) \
+ || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ make \
+ prefix="${D}"/usr \
+ bindir="${D}"/usr/bin \
+ libdir="${D}"/usr/$(get_libdir) \
+ appresdir="${D}"/etc/X11/app-defaults \
+ datadir="${D}"/usr/share \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ docdir="${D}"/usr/share/doc/${PF} \
+ install || die
+
+ # The following links are required for man #123674
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+
+ dodoc BUG-REPORT ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}