summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cinit/cinit-0.1.ebuild')
-rw-r--r--sys-apps/cinit/cinit-0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/cinit/cinit-0.1.ebuild b/sys-apps/cinit/cinit-0.1.ebuild
new file mode 100644
index 000000000000..356e97ca612c
--- /dev/null
+++ b/sys-apps/cinit/cinit-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cinit/cinit-0.1.ebuild,v 1.1 2005/06/24 01:09:58 vapier Exp $
+
+DESCRIPTION="fast executing, small and simple init with support for profiles"
+HOMEPAGE="http://linux.schottelius.org/cinit/"
+SRC_URI="http://linux.schottelius.org/cinit/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ emake \
+ OPTIMIZE="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP=true \
+ all || die "all failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -f "${D}"/sbin/init
+ dodoc Changelog README TODO `find doc -type f`
+}