summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/frobby/ChangeLog9
-rw-r--r--sci-mathematics/frobby/frobby-0.9.0.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/sci-mathematics/frobby/ChangeLog b/sci-mathematics/frobby/ChangeLog
index f4749e4e2dea..50aa5268022b 100644
--- a/sci-mathematics/frobby/ChangeLog
+++ b/sci-mathematics/frobby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/frobby
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.7 2011/11/14 11:26:47 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.8 2012/04/13 16:30:07 tomka Exp $
+
+*frobby-0.9.0 (13 Apr 2012)
+
+ 13 Apr 2012; Thomas Kahle <tomka@gentoo.org> +frobby-0.9.0.ebuild:
+ Bump to 0.9.0
14 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> frobby-0.8.2-r1.ebuild:
QA: cxx conditional was broken, fix it.
diff --git a/sci-mathematics/frobby/frobby-0.9.0.ebuild b/sci-mathematics/frobby/frobby-0.9.0.ebuild
new file mode 100644
index 000000000000..9ab8a918ee34
--- /dev/null
+++ b/sci-mathematics/frobby/frobby-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.9.0.ebuild,v 1.1 2012/04/13 16:30:07 tomka Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Frobby is a software system and project for computations with monomial ideals"
+HOMEPAGE="http://www.broune.com/frobby/"
+SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/frobby_v${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-cflags-no-strip.patch"
+}
+
+src_compile() {
+ emake
+ emake library
+ if use doc; then
+ # latex loops don't parallelize well
+ emake -j1 doc
+ fi
+}
+
+src_install() {
+ dobin bin/frobby
+ dolib.a bin/libfrobby.a
+ insinto /usr/include
+ doins src/frobby.h
+ dodir /usr/include/"${PN}"
+ insinto /usr/include/"${PN}"
+ doins src/stdinc.h
+ if use doc; then
+ dodoc bin/manual.pdf
+ fi
+}