summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/xdrawchem/xdrawchem-1.8.4.ebuild')
-rw-r--r--sci-chemistry/xdrawchem/xdrawchem-1.8.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-chemistry/xdrawchem/xdrawchem-1.8.4.ebuild b/sci-chemistry/xdrawchem/xdrawchem-1.8.4.ebuild
new file mode 100644
index 000000000000..bf70b285a877
--- /dev/null
+++ b/sci-chemistry/xdrawchem/xdrawchem-1.8.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdrawchem/xdrawchem-1.8.4.ebuild,v 1.1 2004/12/24 17:06:38 ribosome Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="a molecular structure drawing program"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3.1.0
+ >=sys-devel/gcc-3.2
+ dev-util/pkgconfig
+ >=sci-chemistry/openbabel-1.100.2*"
+
+src_compile() {
+ append-flags -O0 # incredible compile times otherwise
+ # make sure we use moc from Qt, not from eg media-sound/moc
+ PATH="${QTDIR}/bin:${PATH}"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ cd ${D}/usr/share
+ dodir /usr/share/doc
+ mv xdrawchem/doc doc/xdrawchem
+ dosym /usr/share/doc/xdrawchem /usr/share/xdrawchem/doc
+}