summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog5
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 6f70780e3c76..34504e79c4a2 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/gromacs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.86 2011/06/08 16:21:41 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.87 2011/06/21 06:41:37 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> gromacs-4.5.4-r1.ebuild:
+ Use append-libs
*gromacs-4.5.4-r2 (08 Jun 2011)
diff --git a/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild b/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
index 19bb40ecdd7a..0081695bb7df 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild,v 1.5 2011/05/01 16:49:59 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild,v 1.6 2011/06/21 06:41:37 jlec Exp $
EAPI="4"
@@ -128,8 +128,8 @@ src_configure() {
fi
# if we need external blas or lapack
- use blas && export LIBS+=" $(pkg-config blas --libs)"
- use lapack && export LIBS+=" $(pkg-config lapack --libs)"
+ use blas && append-libs $(pkg-config blas --libs)
+ use lapack && append-libs $(pkg-config lapack --libs)
local sseflag="x86-64-sse"
use x86 && sseflag="ia32-sse"