summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-5.0.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-5.0.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-chemistry/gromacs/gromacs-5.0.ebuild b/sci-chemistry/gromacs/gromacs-5.0.ebuild
index 12b6deeb3629..8f5dfac11044 100644
--- a/sci-chemistry/gromacs/gromacs-5.0.ebuild
+++ b/sci-chemistry/gromacs/gromacs-5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-5.0.ebuild,v 1.3 2014/11/25 16:04:38 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-5.0.ebuild,v 1.4 2015/01/31 20:23:56 ottxor Exp $
EAPI=5
@@ -22,7 +22,7 @@ else
test? ( http://gerrit.gromacs.org/download/regressiontests-${TEST_PV}.tar.gz )"
fi
-ACCE_IUSE="sse2 sse4_1 avx_128_fma avx_256 avx2_256"
+ACCE_IUSE="cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_fma4 cpu_flags_x86_avx cpu_flags_x86_avx2"
DESCRIPTION="The ultimate molecular dynamics simulation package"
HOMEPAGE="http://www.gromacs.org/"
@@ -117,11 +117,11 @@ src_configure() {
#go from slowest to fastest acceleration
local acce="None"
- use sse2 && acce="SSE2"
- use sse4_1 && acce="SSE4.1"
- use avx_128_fma && acce="AVX_128_FMA"
- use avx_256 && acce="AVX_256"
- use avx2_256 && acce="AVX2_256"
+ use cpu_flags_x86_sse2 && acce="SSE2"
+ use cpu_flags_x86_sse4_1 && acce="SSE4.1"
+ use cpu_flags_x86_fma4 && acce="AVX_128_FMA"
+ use cpu_flags_x86_avx && acce="AVX_256"
+ use cpu_flags_x86_avx2 && acce="AVX2_256"
#to create man pages, build tree binaries are executed (bug #398437)
[[ ${CHOST} = *-darwin* ]] && \