summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild')
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index 5c22237acc30..1d5a2b540bb5 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.10 2010/01/01 21:44:45 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.11 2012/04/26 16:06:44 jlec Exp $
+
+EAPI=4
inherit toolchain-funcs
-DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data."
+DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
HOMEPAGE="http://www.tree-puzzle.de"
SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="mpi"
DEPEND="mpi? ( sys-cluster/lam-mpi )"
+RDEPEND="${DEPEND}"
pkg_setup () {
use mpi && [ $(tc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
@@ -21,16 +24,15 @@ pkg_setup () {
version of the program, or use gcc as your compiler (CC=\"gcc\")."
}
-src_compile() {
- econf || die
- cd ${S}/src
+src_prepare() {
if ! use mpi; then
- sed -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
- -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
- -i Makefile || die
+ cd ${S}/src
+ sed \
+ -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
+ -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
+ -i Makefile || die
+ cd ${S}
fi
- cd ${S}
- emake || die
}
src_install() {