summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/ww/ww-2.26.ebuild')
-rw-r--r--net-p2p/ww/ww-2.26.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-p2p/ww/ww-2.26.ebuild b/net-p2p/ww/ww-2.26.ebuild
new file mode 100644
index 000000000000..716352c21b65
--- /dev/null
+++ b/net-p2p/ww/ww-2.26.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ww/ww-2.26.ebuild,v 1.1 2004/10/05 17:20:06 squinky86 Exp $
+
+DESCRIPTION="White Water allows people to publish files for download by thousands of people without saturating their bandwidth."
+HOMEPAGE="http://ww.walrond.org"
+SRC_URI="ftp://ftp.walrond.org/ww/${P}.tar.bz2"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-libs/openssl-0.9.7"
+
+src_compile() {
+ sed -e "s/-O3/${CFLAGS}/g" Makefile > Makefile.$$
+ mv -f Makefile.$$ Makefile || die "moving Makefile"
+ make clean || die "make clean"
+ make deps || die "make deps"
+ make release || die "make release"
+}
+
+src_install() {
+ dodoc INSTALL README
+ dohtml -r www
+ dobin ww
+}