summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/mutella/mutella-0.4.5.ebuild')
-rw-r--r--net-p2p/mutella/mutella-0.4.5.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-p2p/mutella/mutella-0.4.5.ebuild b/net-p2p/mutella/mutella-0.4.5.ebuild
index 03df2eba0db6..42aea7d4f375 100644
--- a/net-p2p/mutella/mutella-0.4.5.ebuild
+++ b/net-p2p/mutella/mutella-0.4.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/mutella-0.4.5.ebuild,v 1.4 2005/04/08 18:03:12 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/mutella-0.4.5.ebuild,v 1.5 2006/06/06 19:55:35 sekretarz Exp $
+
+inherit eutils
DESCRIPTION="Text-mode gnutella client"
SRC_URI="mirror://sourceforge/mutella/${P}.tar.gz"
@@ -12,6 +14,13 @@ IUSE="debug"
DEPEND="virtual/libc
sys-libs/readline"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gcc41.patch
+}
+
src_compile() {
econf --enable-optimization \
`use_enable debug` || die "econf failed"