summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bitcoind/bitcoind-0.9.3-r1.ebuild')
-rw-r--r--net-p2p/bitcoind/bitcoind-0.9.3-r1.ebuild118
1 files changed, 118 insertions, 0 deletions
diff --git a/net-p2p/bitcoind/bitcoind-0.9.3-r1.ebuild b/net-p2p/bitcoind/bitcoind-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..eb9d0b1bd5fa
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.9.3-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.9.3-r1.ebuild,v 1.1 2015/01/10 17:02:08 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+inherit autotools bash-completion-r1 db-use eutils user versionator systemd
+
+MyPV="${PV/_/}"
+MyPN="bitcoin"
+MyP="${MyPN}-${MyPV}"
+LJR_PV="${PV}.ljr20141002"
+LJR_PATCH="bitcoin-${LJR_PV}.patch"
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
+ ljr? ( http://luke.dashjr.org/programs/bitcoin/files/bitcoind/luke-jr/0.9.x/${LJR_PV}/${LJR_PATCH}.xz )
+"
+
+LICENSE="MIT ISC GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples ljr ljr-antispam logrotate test upnp +wallet"
+
+REQUIRED_USE="
+ ljr-antispam? ( ljr )
+"
+RDEPEND="
+ >=dev-libs/boost-1.41.0[threads(+)]
+ dev-libs/openssl:0[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ wallet? (
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ )
+ virtual/bitcoin-leveldb
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+ sys-apps/sed
+"
+
+S="${WORKDIR}/${MyP}"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/0.9-openssl-101k.patch"
+ if use ljr; then
+ epatch "${WORKDIR}/${LJR_PATCH}"
+ use ljr-antispam || epatch "${FILESDIR}/0.9.x-ljr_noblacklist.patch"
+ else
+ epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
+ fi
+ rm -r src/leveldb
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-ccache \
+ $(use_with upnp miniupnpc) $(use_enable upnp upnp-default) \
+ $(use_enable test tests) \
+ $(use_enable wallet) \
+ --with-system-leveldb \
+ --without-cli \
+ --without-gui
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd-r1" ${PN}
+ systemd_dounit "${FILESDIR}/bitcoind.service"
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README.md doc/release-notes.md
+ dodoc doc/tor.md
+ doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,qos,spendfrom,tidy_datadir.sh}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}