summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog7
-rw-r--r--net-mail/fetchmail/Manifest6
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.3.ebuild91
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.3.33
4 files changed, 106 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 1e0db8188f91..6a6b282cbd2b 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.96 2006/03/10 00:33:10 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.97 2006/04/07 20:54:40 ticho Exp $
+
+*fetchmail-6.3.3 (07 Apr 2006)
+
+ 07 Apr 2006; Andrej Kacian <ticho@gentoo.org> +fetchmail-6.3.3.ebuild:
+ Version bump.
10 Mar 2006; Michael Hanselmann <hansmi@gentoo.org>
fetchmail-6.3.2-r1.ebuild:
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 393707d135e4..5719014ffd48 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -10,6 +10,9 @@ SHA256 048a053de9c4f2103d93d2ad2e2c02bfe415e4c8d3b7602a17f834e9088ee10f fetchmai
MD5 70f003b7815ed70d8d8c34291161bdb5 fetchmail-6.3.2.ebuild 2418
RMD160 034b9be55110e2be1737838bf7b7330e13ed2c3a fetchmail-6.3.2.ebuild 2418
SHA256 cdf19f98347ebb7a6020568dcec1516fcaf62b081958466f9501726de1f53ea3 fetchmail-6.3.2.ebuild 2418
+MD5 d8efacce61c34a6cb19687d0508e3518 fetchmail-6.3.3.ebuild 2322
+RMD160 99af1b75b747ca4ecde453f402ae2a8861b323f2 fetchmail-6.3.3.ebuild 2322
+SHA256 842ab310657b984ed3eaaa10fc20b280f0ccb7c3e3315a51ca3d8ea7d2d79222 fetchmail-6.3.3.ebuild 2322
MD5 29d376a1042aeeeba94e911a943d5a7f files/conf.d-fetchmail 347
RMD160 5a042695f6849653d32b17a6852025d1d695770a files/conf.d-fetchmail 347
SHA256 8ba3e51b5a51b42daf8cfa2183c938afb04fd6a9cc941e1adb9faa10aff677bf files/conf.d-fetchmail 347
@@ -22,6 +25,9 @@ SHA256 cbf4560cc00d950ba3abfd0008ef2594473384a8cc1729aa047087bb7e978e90 files/di
MD5 8b357a93d8a5b82f52543ce161eaa4ad files/digest-fetchmail-6.3.2-r1 253
RMD160 dfb77d6510902739dc2898ac4d365ea69080dec0 files/digest-fetchmail-6.3.2-r1 253
SHA256 fde9cffbefb7724cd36272ac635f96d3c1a525167ebdb4c13ce743086e554c2c files/digest-fetchmail-6.3.2-r1 253
+MD5 72b5a859ce4066b3808224321960e71d files/digest-fetchmail-6.3.3 253
+RMD160 1b42b1d3a5597f1afc6704841e9391bd1e9375f3 files/digest-fetchmail-6.3.3 253
+SHA256 26b778415d5ee5230fc9fe12df0c0ad0f23b450f4eef689536b9f74cdbe79c3d files/digest-fetchmail-6.3.3 253
MD5 44ab8af6373e139c7c4b8b8df77b0658 files/fetchmail 591
RMD160 a24c5d093db4e8212ec7307dc070dc35a8da144b files/fetchmail 591
SHA256 0de1c32b1a94755476cd81ba2c846adefb6680414d5e865a85743a1ff091f53f files/fetchmail 591
diff --git a/net-mail/fetchmail/fetchmail-6.3.3.ebuild b/net-mail/fetchmail/fetchmail-6.3.3.ebuild
new file mode 100644
index 000000000000..0b7dc203d92f
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.3.ebuild,v 1.1 2006/04/07 20:54:40 ticho Exp $
+
+inherit eutils gnuconfig
+
+FCONF_P="fetchmailconf-1.43.2"
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ nls? ( sys-devel/gettext )
+ elibc_FreeBSD? ( sys-libs/com_err )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd \${S} failed"
+
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch ${FILESDIR}/${PN}-6.2.5-broken-headers.patch || die
+
+ autoconf
+ gnuconfig_update
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_enable ipv6 inet6) \
+ $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+ # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ newinitd ${FILESDIR}/fetchmail fetchmail
+ newconfd ${FILESDIR}/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.3.3 b/net-mail/fetchmail/files/digest-fetchmail-6.3.3
new file mode 100644
index 000000000000..c794525de0b5
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.3.3
@@ -0,0 +1,3 @@
+MD5 d6f6ecd02fa5c92b84d44fe031067938 fetchmail-6.3.3.tar.bz2 1197241
+RMD160 45af0dd59976779875b683a98b94f68ffed02120 fetchmail-6.3.3.tar.bz2 1197241
+SHA256 bd53e23b0210a831c9ce6765f49904e1d996aaca5d1e95ebacead35a06f3304a fetchmail-6.3.3.tar.bz2 1197241