summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnids/libnids-1.16.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.16.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libnids/libnids-1.16.ebuild b/net-libs/libnids/libnids-1.16.ebuild
new file mode 100644
index 000000000000..42f1d30ac913
--- /dev/null
+++ b/net-libs/libnids/libnids-1.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.16.ebuild,v 1.1 2001/12/02 01:26:36 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Libnids is an implementation of an E-component of Network Intrusion Detection System. It emulates the IP stack of Linux 2.0.x. Libnids offers IP defragmentation, TCP stream assembly and TCP port scan detection."
+SRC_URI="http://www.packetfactory.net/Projects/Libnids/dist/${P}.tar.gz"
+HOMEPAGE="http://www.packetfactory.net/Projects/Libnids/"
+DEPEND="net-libs/libpcap net-libs/libnet"
+
+
+src_compile() {
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+ assert
+
+ make || die
+}
+
+src_install () {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
+
+ dodoc CHANGES COPYING CREDITS MISC README
+
+}
+