summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/scrollz/scrollz-1.9.ebuild')
-rw-r--r--net-irc/scrollz/scrollz-1.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-irc/scrollz/scrollz-1.9.ebuild b/net-irc/scrollz/scrollz-1.9.ebuild
new file mode 100644
index 000000000000..b86525220f65
--- /dev/null
+++ b/net-irc/scrollz/scrollz-1.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/scrollz/scrollz-1.9.ebuild,v 1.1 2003/06/30 01:01:59 vapier Exp $
+
+DESCRIPTION="Advanced IRC client based on ircII"
+SRC_URI="ftp://ftp.scrollz.com/pub/ScrollZ/source/ScrollZ-${PV}.tar.gz"
+HOMEPAGE="http://www.scrollz.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ipv6 socks5 ssl"
+
+DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/ScrollZ-${PV}
+
+src_compile() {
+ econf \
+ --with-default-server=localhost \
+ `use_enable ipv6` \
+ `use_enable socks5` \
+ `use_with ssl` \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall sharedir=${D}/usr/share install || die
+ dodoc README.ScrollZ ChangeLog* README* todo
+}