summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtwitter/ChangeLog7
-rw-r--r--net-im/qtwitter/qtwitter-0.8.1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index 1c7ccd84fba5..53db099a22df 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.8 2009/07/14 19:07:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.9 2009/07/16 12:17:09 hwoarang Exp $
+
+*qtwitter-0.8.1 (16 Jul 2009)
+
+ 16 Jul 2009; Markos Chandras <hwoarang@gentoo.org> +qtwitter-0.8.1.ebuild:
+ Version bump
14 Jul 2009; Markos Chandras <hwoarang@gentoo.org> qtwitter-0.8.0.ebuild:
Fix linguas
diff --git a/net-im/qtwitter/qtwitter-0.8.1.ebuild b/net-im/qtwitter/qtwitter-0.8.1.ebuild
new file mode 100644
index 000000000000..e5ed49c8cc89
--- /dev/null
+++ b/net-im/qtwitter/qtwitter-0.8.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.8.1.ebuild,v 1.1 2009/07/16 12:17:09 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+DESCRIPTION="A Qt-based client for Twitter and Identi.ca"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
+SRC_URI="http://files.ayoy.net/qtwitter/release/${PV}/src/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +oauth"
+
+DEPEND="x11-libs/qt-gui:4
+ oauth? ( dev-libs/qoauth )"
+RDEPEND="${DEPEND}"
+
+QTWITTER_LANGS="pt_BR"
+QTWITTER_NOLONGLANGS="ca_ES de_DE es_ES fr_FR ja_JP pl_PL"
+
+for L in $QTWITTER_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $QTWITTER_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ qt4_src_prepare
+ echo "CONFIG += nostrip" >> "${S}"/${PN}.pro
+
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $QTWITTER_LANGS; then
+ langs="$langs loc/${PN}_${lingua}.ts"
+ else
+ for a in $QTWITTER_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs loc/${PN}_${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove translations and add only the selected ones
+ sed -i -e '/^ *loc.*\.ts/d' \
+ -e "/^TRANSLATIONS/s:loc.*:${langs}:" \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+ # first line fixes bug about unsecure runpaths
+ # second disables docs installation by make (done by dodoc in install)
+ sed -i -e '/-Wl,-rpath,\$\${TOP}/d' \
+ -e '/doc \\/d' \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+
+ sed -i "s!\(\$\${INSTALL_PREFIX}\)/lib!\1/$(get_libdir)!" \
+ twitterapi/twitterapi.pro urlshortener/urlshortener.pro || die "sed failed"
+
+ use oauth || sed -i '/DEFINES += OAUTH/d' ${PN}.pri
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README CHANGELOG || die "dodoc failed"
+}