summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/twinkle/twinkle-0.3.1.ebuild')
-rw-r--r--net-im/twinkle/twinkle-0.3.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/twinkle/twinkle-0.3.1.ebuild b/net-im/twinkle/twinkle-0.3.1.ebuild
new file mode 100644
index 000000000000..af8e89e01847
--- /dev/null
+++ b/net-im/twinkle/twinkle-0.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-0.3.1.ebuild,v 1.1 2005/10/17 19:14:36 dragonheart Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="Twinkle is a soft phone for your VOIP communcations using SIP."
+HOMEPAGE="http://www.twinklephone.com/"
+SRC_URI="http://www.xs4all.nl/~mfnboer/twinkle/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Requires libqt-mt actually... Is that *always* built, or do we need to check?
+RDEPEND=">=net-libs/ccrtp-1.3.4
+ >=x11-libs/qt-3.3.4-r6
+ >=dev-cpp/commoncpp2-1.3.0"
+
+DEPEND="${REDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-badcflags.patch
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS NEWS README THANKS
+}