summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/curphoo/curphoo-0.3.7.ebuild')
-rw-r--r--net-im/curphoo/curphoo-0.3.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-im/curphoo/curphoo-0.3.7.ebuild b/net-im/curphoo/curphoo-0.3.7.ebuild
new file mode 100644
index 000000000000..c8c0fe14623c
--- /dev/null
+++ b/net-im/curphoo/curphoo-0.3.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/curphoo/curphoo-0.3.7.ebuild,v 1.1 2003/10/08 14:16:43 lanius Exp $
+
+DESCRIPTION="Curphoo is a console Yahoo! Chat client written in Python"
+HOMEPAGE="http://www.waduck.com/~curphoo/"
+SRC_URI="http://www.waduck.com/~curphoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc "
+
+RDEPEND="virtual/glibc >=dev-lang/python-2.1 >=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${FILESDIR}/curphoo.sh curphoo.sh.templ
+ sed -e "s#@PHOOPATH@#${P}#" curphoo.sh.templ >curphoo.sh
+}
+
+src_compile() {
+ make || die
+}
+
+src_install () {
+ dodoc BUGS CHANGELOG README TODO floo2phoo
+ dodir /usr/lib/${P}
+ mv curphoo curphoo.py
+ cp *.py *.so ${D}/usr/lib/${P}
+
+ mv curphoo.sh curphoo
+ dobin curphoo
+}