summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp/lftp-2.6.7.ebuild')
-rw-r--r--net-ftp/lftp/lftp-2.6.7.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-ftp/lftp/lftp-2.6.7.ebuild b/net-ftp/lftp/lftp-2.6.7.ebuild
new file mode 100644
index 000000000000..89a5fd32e2cc
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.7.ebuild,v 1.1 2003/09/20 03:59:00 iggy Exp $
+
+IUSE="ssl socks5 nls alpha"
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf}
+
+ [ "${ARCH}" == "alpha" ] && {
+ # remove duplicate libraries, causes problems on ALPHA.
+ # -taviso
+ einfo "Adding check for superfluous linking..."
+ sed -i \
+ 's/\(link_command="\)\($compile_command$compile_rpath\)"/\1\`echo \2 | perl -lane \x27print "@F" if @F = grep \!\$seen{\$_}++, @F\x27\`"/' \
+ libtool
+ }
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}