summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild')
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild
index 7ac295cf7648..4fa55a24e974 100644
--- a/net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild,v 1.13 2007/01/05 10:18:43 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-pppoe/rp-pppoe-3.8.ebuild,v 1.14 2007/03/10 14:22:46 mrness Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -56,14 +56,8 @@ src_install () {
make RPM_INSTALL_ROOT="${D}" docdir=/usr/share/doc/${PF} install \
|| die "install failed"
- #Don't use compiled rp-pppoe plugin; use it from the current version of pppd
+ #Don't use compiled rp-pppoe plugin - see pkg_preinst below
rm "${D}/etc/ppp/plugins/rp-pppoe.so"
- local PPPD_VER=`best_version net-dialup/ppp`
- PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
- PPPD_VER=${PPPD_VER%%-*} #reduce it to ${PV}
- if [ -n "${PPPD_VER}" ] && [ -f "${ROOT}/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" ] ; then
- dosym /usr/lib/pppd/${PPPD_VER}/rp-pppoe.so /etc/ppp/plugins/rp-pppoe.so
- fi
prepalldocs
@@ -74,6 +68,16 @@ src_install () {
fi
}
+pkg_preinst() {
+ # Use the rp-pppoe plugin that comes with net-dialup/pppd
+ local PPPD_VER=`best_version net-dialup/ppp`
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%-*} #reduce it to ${PV}
+ if [ -n "${PPPD_VER}" ] && [ -f "${ROOT}/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" ] ; then
+ dosym /usr/lib/pppd/${PPPD_VER}/rp-pppoe.so /etc/ppp/plugins/rp-pppoe.so
+ fi
+}
+
pkg_postinst() {
einfo "Use pppoe-setup to configure your dialup connection."
}