summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sarg/sarg-1.4.1-r1.ebuild')
-rw-r--r--net-analyzer/sarg/sarg-1.4.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/sarg/sarg-1.4.1-r1.ebuild b/net-analyzer/sarg/sarg-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..51524d0f0ed7
--- /dev/null
+++ b/net-analyzer/sarg/sarg-1.4.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="Sarg (Squid Analysis Report Generator) is a tool that allows you to view where your users are going to on the Internet."
+HOMEPAGE="http://web.onda.com.br/orso/sarg.html"
+SRC_URI="http://web.onda.com.br/orso/${P}.tar.gz http://web.onda.com.br/orso/patches/sarg-1.4.1-index.sort.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=""
+RDEPEND=">=net-www/squid-2.5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${DISTDIR}/sarg-1.4.1-index.sort.patch
+}
+
+src_compile() {
+ rm -rf config.cache
+ ./configure \
+ --enable-bindir=/usr/bin \
+ --enable-mandir=/usr/man/man1 \
+ --enable-sysconfdir=/etc/sarg || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /etc/sarg /usr/bin /usr/man/man1
+ make \
+ BINDIR=${D}/usr/bin \
+ MANDIR=${D}/usr/man/man1 \
+ SYSCONFDIR=${D}/etc/sarg \
+ install || die
+}