summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pchar/pchar-1.5.ebuild')
-rw-r--r--net-analyzer/pchar/pchar-1.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/pchar/pchar-1.5.ebuild b/net-analyzer/pchar/pchar-1.5.ebuild
new file mode 100644
index 000000000000..ea0a2f7350c4
--- /dev/null
+++ b/net-analyzer/pchar/pchar-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pchar/pchar-1.5.ebuild,v 1.1 2006/03/23 22:31:07 chutzpah Exp $
+
+DESCRIPTION="Internet bandwidth, latency, and loss of links analyzer."
+HOMEPAGE="http://www.kitchenlab.org/www/bmah/Software/pchar/"
+SRC_URI="http://www.kitchenlab.org/www/bmah/Software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 snmp pcap"
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ pcap? ( net-libs/libpcap )
+ snmp? ( >=net-analyzer/net-snmp-5.0.0 )"
+
+src_compile() {
+ econf --without-suid \
+ $(use_with ipv6) \
+ $(use_with snmp snmp /usr/lib) \
+ $(use_with pcap)
+}
+
+src_install() {
+ einstall
+ dodoc FAQ CHANGES README
+}