summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/matroxset/matroxset-0.4.ebuild')
-rw-r--r--media-video/matroxset/matroxset-0.4.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/media-video/matroxset/matroxset-0.4.ebuild b/media-video/matroxset/matroxset-0.4.ebuild
index 6d34aa86e5ce..a21e91214476 100644
--- a/media-video/matroxset/matroxset-0.4.ebuild
+++ b/media-video/matroxset/matroxset-0.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/matroxset/matroxset-0.4.ebuild,v 1.5 2007/11/27 12:15:19 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/matroxset/matroxset-0.4.ebuild,v 1.6 2009/06/02 10:29:45 flameeyes Exp $
+
+inherit toolchain-funcs
IUSE=""
@@ -8,16 +10,23 @@ DESCRIPTION="Matrox utility to switch output modes (activate tvout)"
HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/"
SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/${P}.tar.gz"
-DEPEND="virtual/libc
- sys-libs/ncurses"
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc x86"
+doecho() {
+ echo "$@"
+ "$@"
+}
+
src_compile() {
-# make clean || die
- make all || die
+ doecho $(tc-getCC) -o ${PN} \
+ ${CFLAGS} ${LDFLAGS} \
+ ${PN}.c -lncurses \
+ || die "build failed"
#prepare small README
cat >> "${S}"/README << _EOF_
@@ -30,7 +39,7 @@ _EOF_
}
src_install() {
- dobin matroxset
+ dobin matroxset || die
- dodoc README
+ dodoc README || die
}