summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/isight-firmware-tools/isight-firmware-tools-0.5.1.1.ebuild')
-rw-r--r--media-video/isight-firmware-tools/isight-firmware-tools-0.5.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-video/isight-firmware-tools/isight-firmware-tools-0.5.1.1.ebuild b/media-video/isight-firmware-tools/isight-firmware-tools-0.5.1.1.ebuild
new file mode 100644
index 000000000000..a4faaf923f7f
--- /dev/null
+++ b/media-video/isight-firmware-tools/isight-firmware-tools-0.5.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/isight-firmware-tools/isight-firmware-tools-0.5.1.1.ebuild,v 1.1 2007/12/19 11:30:44 genstef Exp $
+
+DESCRIPTION="Extract, load or export firmware for the iSight webcams"
+HOMEPAGE="http://bersace03.free.fr/ift/"
+SRC_URI="http://bersace03.free.fr/ift/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/glib
+ dev-libs/libusb
+ dev-libs/libgcrypt"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ elog "You need to extract your firmware prior to being able to loading it"
+ elog "ift-extract --apple-driver /macos/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport"
+ elog "If you do not have OSX you can get AppleUSBVideoSupport from"
+ elog "http://www.mediafire.com/?81xtkqyttjt"
+}