summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/vcr/ChangeLog41
-rw-r--r--media-tv/vcr/Manifest8
-rw-r--r--media-tv/vcr/files/1.09-r2-gentoo.diff146
-rw-r--r--media-tv/vcr/files/digest-vcr-1.09-r12
-rw-r--r--media-tv/vcr/files/digest-vcr-1.09-r22
-rw-r--r--media-tv/vcr/vcr-1.09-r1.ebuild33
-rw-r--r--media-tv/vcr/vcr-1.09-r2.ebuild46
7 files changed, 274 insertions, 4 deletions
diff --git a/media-tv/vcr/ChangeLog b/media-tv/vcr/ChangeLog
new file mode 100644
index 000000000000..fe217b73eb84
--- /dev/null
+++ b/media-tv/vcr/ChangeLog
@@ -0,0 +1,41 @@
+# ChangeLog for media-tv/vcr
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/ChangeLog,v 1.1 2003/06/18 12:09:42 seemant Exp $
+
+*vcr-1.09-r2 (18 Jun 2003)
+
+ 18 Jun 2003; Seemant Kulleen <seemant@gentoo.org> vcr-1.09-r1.ebuild,
+ vcr-1.09-r2.ebuild, files/1.09-r2-gentoo.diff:
+ moved to media-tv
+
+*vcr-1.09-r2 (21 Oct 2002)
+
+ 21 Feb 2003; Martin Holzer <mholzer@gentoo.org> vcr-1.09-r2.ebuild :
+ Compiles only with avifile-0.7.15. Closes #15886.
+
+ 22 Oct 2002; Nick Hadaway <raker@gentoo.org> vcr-1.09-r2.ebuild :
+ Marked as stable now as patch has been tested on gcc3 and gcc2 systems
+ and compiles without errors.
+
+ 21 Oct 2002; Nick Hadaway <raker@gentoo.org> vcr-1.09-r2.ebuild,
+ digest-vcr-1.09-r2, 1.09-r2-gentoo.diff :
+ Patched the c++ code so it compiled without any errors. Currently
+ marked unstable until I get some test reports back. See bug #9265
+
+*vcr-1.09-r1 (14 Sep 2002)
+
+ 21 Feb 2003; Martin Holzer <mholzer@gentoo.org> vcr-1.09-r1.ebuild :
+ Compiles only with avifile-0.7.15. Closes #15886.
+
+ 14 Sep 2002; Seemant Kulleen <seemant@gentoo.org> vcr-1.09-r1.ebuild
+ files/digest-vcr-1.09-r1 :
+ Fix for flipped vcr output submitted by gentoo@liquidx.net (Alastair Tse)
+ in bug #7919. Moved patches to one patchfile and it now resides on
+ ibiblio instead.
+
+*vcr-1.09 (13 July 2002)
+
+ 13 Jul 2002; phoen][x <phoenix@gentoo.org> ChangeLog, vcr-1.09.ebuild,
+ files/digest-vcr-1.09, files/vcr-1.09-avifile-0.7x.patch :
+ Initial cvs commit. Ebuild contributed by Alastair Tse <gentoo@liquidx.net>.
+ Thanks for the contribution.
diff --git a/media-tv/vcr/Manifest b/media-tv/vcr/Manifest
index 19908e5eb7cc..f7605c9c28e4 100644
--- a/media-tv/vcr/Manifest
+++ b/media-tv/vcr/Manifest
@@ -1,6 +1,6 @@
-MD5 4db2cab25c039cba306fd1b0f81f6560 ChangeLog 1476
-MD5 e27ebc24aa73dbe4f1a00bc95072f9a5 vcr-1.09-r1.ebuild 832
-MD5 f537d1b133ca8dac01573d553c6a300c vcr-1.09-r2.ebuild 837
-MD5 58b7876f0d814d0e752b60670c0ca0af files/1.09-r2-gentoo.diff 3837
+MD5 82304d8ec9906ef504058b54e811aaf3 vcr-1.09-r1.ebuild 829
+MD5 bac607822e934468f94aaf1cb45de177 vcr-1.09-r2.ebuild 834
+MD5 dc7ed905729167868cb3bdf538572f82 ChangeLog 1640
MD5 f2aab865a8c5b77eba4bf28e0177a511 files/digest-vcr-1.09-r1 127
MD5 10122efa3abc58adb5f486f84d27fac6 files/digest-vcr-1.09-r2 122
+MD5 58b7876f0d814d0e752b60670c0ca0af files/1.09-r2-gentoo.diff 3837
diff --git a/media-tv/vcr/files/1.09-r2-gentoo.diff b/media-tv/vcr/files/1.09-r2-gentoo.diff
new file mode 100644
index 000000000000..9a2226fbb313
--- /dev/null
+++ b/media-tv/vcr/files/1.09-r2-gentoo.diff
@@ -0,0 +1,146 @@
+diff -urN vcr-1.09/src/capproc.cc vcr-1.09-modified/src/capproc.cc
+--- vcr-1.09/src/capproc.cc 2001-11-11 08:39:22.000000000 -0600
++++ vcr-1.09-modified/src/capproc.cc 2002-10-21 14:29:55.000000000 -0500
+@@ -5,6 +5,7 @@
+ #include <avifile.h>
+ #include <videoencoder.h>
+ #include <iostream>
++#include <sstream>
+
+ #ifdef OLDAVIFILE
+ # include <aviutil.h>
+diff -urN vcr-1.09/src/capproc.h vcr-1.09-modified/src/capproc.h
+--- vcr-1.09/src/capproc.h 2001-07-27 17:05:54.000000000 -0500
++++ vcr-1.09-modified/src/capproc.h 2002-10-21 14:44:31.000000000 -0500
+@@ -1,6 +1,6 @@
+ #include <queue>
+ #include <string>
+-#include <strstream>
++#include <sstream>
+ #include <pthread.h>
+ #include "v4lxif.h"
+ #include "vcr.h"
+@@ -88,8 +88,8 @@
+ int comp_drop;
+ long long starttime;
+
+- std::strstream* messenger;
+- std::strstream def_mess;
++ std::ostringstream* messenger;
++ std::ostringstream def_mess;
+
+ std::string filename;
+ int segment_size;
+@@ -187,7 +187,7 @@
+ {
+ m_quit = 1;
+ }
+- void setMessenger(std::strstream& mess)
++ void setMessenger(std::ostringstream& mess)
+ {
+ messenger=&mess;
+ }
+diff -urN vcr-1.09/src/main.cc vcr-1.09-modified/src/main.cc
+--- vcr-1.09/src/main.cc 2001-11-11 08:38:36.000000000 -0600
++++ vcr-1.09-modified/src/main.cc 2002-10-21 15:00:16.000000000 -0500
+@@ -16,7 +16,7 @@
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+-#include <iostream.h>
++#include <iostream>
+ /* Custom headerfiles */
+
+ #include "vcr.h"
+@@ -134,7 +134,7 @@
+ resolution_width = 0,
+ resolution_height = 0;
+ #ifdef OLDAVIFILE
+-vector<AttributeInfo>
++std::vector<AttributeInfo>
+ #else
+ avm::vector<AttributeInfo>
+ #endif
+@@ -498,10 +498,9 @@
+ fprintf(stderr, "\n");
+ }
+
+-void
+-list_codecs()
++void list_codecs()
+ {
+- vector<CodecInfo>::iterator it;
++ avm::vector<CodecInfo>::iterator it;
+
+ fprintf(stderr, "Available codecs: \n\n");
+
+@@ -549,14 +548,14 @@
+ return;
+
+ #ifdef OLDAVIFILE
+- vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
++ std::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
+ #else
+ avm::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
+ #endif
+
+ fprintf(stderr, "These attributes are supported for this codec:\n\n");
+
+- vector<AttributeInfo>::const_iterator it;
++ avm::vector<AttributeInfo>::const_iterator it;
+ for(it=encinfo.begin(); it!=encinfo.end(); it++)
+ {
+ #ifdef OLDAVIFILE
+@@ -587,9 +586,9 @@
+ fprintf(stderr, "\tPossible values: ");
+
+ #ifdef OLDAVIFILE
+- vector<string>::const_iterator sit;
++ std::vector<string>::const_iterator sit;
+ #else
+- vector<avm::string>::const_iterator sit;
++ avm::vector<avm::string>::const_iterator sit;
+ #endif
+ for (sit=(it->options).begin(); sit!=(it->options).end(); sit++)
+ fprintf(stderr, "\"%s\" ", sit->c_str());
+@@ -805,7 +804,7 @@
+ int
+ found_codec = -1;
+
+- vector<CodecInfo>::iterator it;
++ avm::vector<CodecInfo>::iterator it;
+
+ for (it = video_codecs.begin(); it != video_codecs.end(); it++)
+ {
+@@ -1003,7 +1002,7 @@
+ int
+ get_codec_index(int fourcc)
+ {
+- vector<CodecInfo>::iterator it;
++ avm::vector<CodecInfo>::iterator it;
+ int i = 0;
+
+ for (it = video_codecs.begin(); it != video_codecs.end(); it++)
+@@ -1017,19 +1016,18 @@
+ }
+
+ //TODO: It ignores fourcc currently..
+-short
+-set_attribute(int fourcc, const char *attr, const char *val)
++short set_attribute(int fourcc, const char *attr, const char *val)
+ {
+ int setval = 0;
+ int retval = 0;
+
+- vector<AttributeInfo>::const_iterator it;
++ avm::vector<AttributeInfo>::const_iterator it;
+ int idx = get_codec_index(fourcc);
+ if (idx < 0)
+ return 0;
+
+ #ifdef OLDAVIFILE
+- vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
++ std::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
+ #else
+ avm::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
+ #endif
diff --git a/media-tv/vcr/files/digest-vcr-1.09-r1 b/media-tv/vcr/files/digest-vcr-1.09-r1
new file mode 100644
index 000000000000..88717d8cf0c8
--- /dev/null
+++ b/media-tv/vcr/files/digest-vcr-1.09-r1
@@ -0,0 +1,2 @@
+MD5 18a41f998647b8e32f07de3c9f899009 vcr-1.09.tar.gz 117377
+MD5 5b5238d60567080f7c9fbf53d023273f vcr-1.09-gentoo.diff.bz2 1678
diff --git a/media-tv/vcr/files/digest-vcr-1.09-r2 b/media-tv/vcr/files/digest-vcr-1.09-r2
new file mode 100644
index 000000000000..c75848ea1ecb
--- /dev/null
+++ b/media-tv/vcr/files/digest-vcr-1.09-r2
@@ -0,0 +1,2 @@
+MD5 18a41f998647b8e32f07de3c9f899009 vcr-1.09.tar.gz 117377
+MD5 f05957fcc83f7c890734e093eda2bd99 vcr_1.09-11.diff.gz 5169
diff --git a/media-tv/vcr/vcr-1.09-r1.ebuild b/media-tv/vcr/vcr-1.09-r1.ebuild
new file mode 100644
index 000000000000..067a684a43e5
--- /dev/null
+++ b/media-tv/vcr/vcr-1.09-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/vcr-1.09-r1.ebuild,v 1.1 2003/06/18 12:09:42 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="VCR - Linux Console VCR"
+SRC_URI="http://www.stack.nl/~brama/${PN}/src/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+HOMEPAGE="http://www.stack.nl/~brama/vcr/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="=media-video/avifile-0.7.15*"
+
+src_unpack () {
+ unpack ${P}.tar.gz
+ ( bzcat ${DISTDIR}/${P}-gentoo.diff.bz2 | patch -p0 ) || die
+}
+
+src_compile () {
+ local myconf
+ myconf="--enable-avifile-0_6"
+ econf ${myconf} || die "econf died"
+ emake || die "emake died"
+}
+
+src_install () {
+
+ einstall || die "einstall died"
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
diff --git a/media-tv/vcr/vcr-1.09-r2.ebuild b/media-tv/vcr/vcr-1.09-r2.ebuild
new file mode 100644
index 000000000000..3b44cf21dfd0
--- /dev/null
+++ b/media-tv/vcr/vcr-1.09-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/vcr-1.09-r2.ebuild,v 1.1 2003/06/18 12:09:42 seemant Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="VCR - Linux Console VCR"
+SRC_URI="http://www.stack.nl/~brama/${PN}/src/${P}.tar.gz"
+HOMEPAGE="http://www.stack.nl/~brama/vcr/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="=media-video/avifile-0.7.15*"
+
+src_unpack () {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/1.09-r2-gentoo.diff || die "patch failed"
+
+}
+
+src_compile () {
+
+ local myconf
+ myconf="--enable-avifile-0_6"
+
+ export CXX="g++"
+
+ econf ${myconf} || die "econf died"
+
+ make || die "emake died"
+
+}
+
+src_install () {
+
+ einstall || die "einstall died"
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+
+}