summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/adjustableclock/adjustableclock-4.1.3.ebuild')
-rw-r--r--kde-misc/adjustableclock/adjustableclock-4.1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-misc/adjustableclock/adjustableclock-4.1.3.ebuild b/kde-misc/adjustableclock/adjustableclock-4.1.3.ebuild
new file mode 100644
index 000000000000..3d87438e2e83
--- /dev/null
+++ b/kde-misc/adjustableclock/adjustableclock-4.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/adjustableclock/adjustableclock-4.1.3.ebuild,v 1.1 2014/01/21 02:30:07 mrueg Exp $
+
+EAPI=5
+
+KDE_LINGUAS_DIR="applet/locale"
+KDE_LINGUAS="de et pl pt pt_BR sv tr uk"
+inherit kde4-base
+
+DESCRIPTION="Plasmoid to show date and time in adjustable format using rich text."
+HOMEPAGE="http://kde-look.org/content/show.php/Adjustable+Clock?content=92825"
+SRC_URI="http://kde-look.org/CONTENT/content-files/92825-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep libplasmaclock)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ local lang
+ for lang in ${KDE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm ${KDE_LINGUAS_DIR}/${lang}.mo
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "Version 4.0 (and newer) is not backwards compatible with 3.x."
+ elog "All custom formats need to be exported and manually converted."
+}