summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kopete/ChangeLog6
-rw-r--r--kde-base/kopete/files/kopete-3.5.9-icq-protocol-change.patch22
-rw-r--r--kde-base/kopete/kopete-3.5.9.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 76141bfa8ed2..8c8c8bc7f641 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.152 2008/06/09 15:18:09 keytoaster Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.153 2008/07/04 16:15:37 keytoaster Exp $
+
+ 04 Jul 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +files/kopete-3.5.9-icq-protocol-change.patch, kopete-3.5.9.ebuild:
+ Include patch to fix bug #224721 if kopete's autoupdate fails.
09 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org> -kopete-4.0.2.ebuild,
-kopete-4.0.3.ebuild:
diff --git a/kde-base/kopete/files/kopete-3.5.9-icq-protocol-change.patch b/kde-base/kopete/files/kopete-3.5.9-icq-protocol-change.patch
new file mode 100644
index 000000000000..f0de7e690678
--- /dev/null
+++ b/kde-base/kopete/files/kopete-3.5.9-icq-protocol-change.patch
@@ -0,0 +1,22 @@
+diff -Naur kdenetwork-3.5.9.orig/kopete/protocols/oscar/oscarversionupdater.cpp kdenetwork-3.5.9/kopete/protocols/oscar/oscarversionupdater.cpp
+--- kdenetwork-3.5.9.orig/kopete/protocols/oscar/oscarversionupdater.cpp 2008-02-14 01:11:52.000000000 +0100
++++ kdenetwork-3.5.9/kopete/protocols/oscar/oscarversionupdater.cpp 2008-07-01 20:06:00.000000000 +0200
+@@ -89,13 +89,13 @@
+ kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << endl;
+ KConfigGroup config( KGlobal::config(), "ICQVersion" );
+
+- mICQVersion.clientString = config.readEntry( "ClientString", "ICQBasic" );
++ mICQVersion.clientString = config.readEntry( "ClientString", "ICQ Client" );
+ mICQVersion.clientId = config.readEntry( "ClientId", "0x010A" ).toUShort( 0, 0 );
+- mICQVersion.major = config.readEntry( "Major", "0x0014" ).toUShort( 0, 0 );
+- mICQVersion.minor = config.readEntry( "Minor", "0x0034" ).toUShort( 0, 0 );
++ mICQVersion.major = config.readEntry( "Major", "0x0006" ).toUShort( 0, 0 );
++ mICQVersion.minor = config.readEntry( "Minor", "0x0000" ).toUShort( 0, 0 );
+ mICQVersion.point = config.readEntry( "Point", "0x0000" ).toUShort( 0, 0 );
+- mICQVersion.build = config.readEntry( "Build", "0x0BB8" ).toUShort( 0, 0 );
+- mICQVersion.other = config.readEntry( "Other", "0x0000043D" ).toUInt( 0, 0 );
++ mICQVersion.build = config.readEntry( "Build", "0x17AB" ).toUShort( 0, 0 );
++ mICQVersion.other = config.readEntry( "Other", "0x00007535" ).toUInt( 0, 0 );
+ mICQVersion.country = config.readEntry( "Country", "us" );
+ mICQVersion.lang = config.readEntry( "Lang", "en" );
+ }
diff --git a/kde-base/kopete/kopete-3.5.9.ebuild b/kde-base/kopete/kopete-3.5.9.ebuild
index bee04ebe1ee6..e4da0c8d6f7d 100644
--- a/kde-base/kopete/kopete-3.5.9.ebuild
+++ b/kde-base/kopete/kopete-3.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.9.ebuild,v 1.7 2008/05/18 16:38:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.9.ebuild,v 1.8 2008/07/04 16:15:37 keytoaster Exp $
KMNAME=kdenetwork
EAPI="1"
@@ -77,6 +77,7 @@ src_unpack() {
epatch "${FILESDIR}/kopete-0.12_alpha1-xscreensaver.patch"
epatch "${FILESDIR}/${PN}-3.5.5-icqfix.patch"
epatch "${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch"
+ epatch "${FILESDIR}/${P}-icq-protocol-change.patch"
use latex || kopete_disable plugin latex
use crypt || kopete_disable plugin cryptography