summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog8
-rw-r--r--kde-base/ksysguard/ksysguard-4.11.6.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index d7ef6f09710d..33cc54269835 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.320 2014/01/20 08:00:13 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.321 2014/02/06 23:20:11 dilfridge Exp $
+
+*ksysguard-4.11.6 (06 Feb 2014)
+
+ 06 Feb 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +ksysguard-4.11.6.ebuild:
+ Version bump KDE SC 4.11.6
20 Jan 2014; Michael Palimaka <kensington@gentoo.org> ksysguard-4.11.5.ebuild:
Restore keywords that were accidentally omitted.
diff --git a/kde-base/ksysguard/ksysguard-4.11.6.ebuild b/kde-base/ksysguard/ksysguard-4.11.6.ebuild
new file mode 100644
index 000000000000..ab3af7f7be35
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.11.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.11.6.ebuild,v 1.1 2014/02/06 23:20:11 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+CPPUNIT_REQUIRED="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+HOMEPAGE+=" http://userbase.kde.org/KSysGuard"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors test"
+
+DEPEND="
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# bug 393091
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}