summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kremotecontrol/kremotecontrol-4.5.3.ebuild')
-rw-r--r--kde-base/kremotecontrol/kremotecontrol-4.5.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-base/kremotecontrol/kremotecontrol-4.5.3.ebuild b/kde-base/kremotecontrol/kremotecontrol-4.5.3.ebuild
new file mode 100644
index 000000000000..21a33170f670
--- /dev/null
+++ b/kde-base/kremotecontrol/kremotecontrol-4.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kremotecontrol/kremotecontrol-4.5.3.ebuild,v 1.1 2010/11/03 16:30:50 scarabeus Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE frontend for remote controls"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep solid)
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kcontrol/kremotecontrol"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ sed -e 's:${KDE4WORKSPACE_SOLIDCONTROL_LIBRARY}:solidcontrol:g' \
+ -i kremotecontrol/{kcmremotecontrol,kded,krcdnotifieritem,libkremotecontrol}/CMakeLists.txt \
+ || die
+}