summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kpdf/kpdf-3.4.2-r2.ebuild')
-rw-r--r--kde-base/kpdf/kpdf-3.4.2-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kpdf/kpdf-3.4.2-r2.ebuild b/kde-base/kpdf/kpdf-3.4.2-r2.ebuild
new file mode 100644
index 000000000000..d35a06ab88b0
--- /dev/null
+++ b/kde-base/kpdf/kpdf-3.4.2-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.4.2-r2.ebuild,v 1.1 2005/08/06 19:41:53 flameeyes Exp $
+
+KMNAME=kdegraphics
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="kpdf, a kde pdf viewer based on xpdf"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nodrm"
+KMEXTRA="kfile-plugins/pdf"
+
+DEPEND=">=media-libs/freetype-2.0.5 media-libs/t1lib"
+
+# Fix regression in kpdf (kde bug 110000). Applied for 3.4.3.
+# Fix crash in kpdf (kde bug 110111). Applied for 3.4.3.
+PATCHES1="${FILESDIR}/kdegraphics-3.4.2-kpdf-fix.patch
+ ${FILESDIR}/kdegraphics-3.4.2-kpdf-contentcrash.patch"
+
+src_compile() {
+ myconf="${myconf} $(use_enable !nodrm kpdf-drm)"
+
+ kde-meta_src_compile
+}