summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdesu')
-rw-r--r--kde-base/kdesu/ChangeLog7
-rw-r--r--kde-base/kdesu/kdesu-4.7.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/kde-base/kdesu/ChangeLog b/kde-base/kdesu/ChangeLog
index d40aec8ddc98..41c928fb6482 100644
--- a/kde-base/kdesu/ChangeLog
+++ b/kde-base/kdesu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdesu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/ChangeLog,v 1.184 2011/07/09 15:14:23 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/ChangeLog,v 1.185 2011/07/27 14:04:27 alexxy Exp $
+
+*kdesu-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +kdesu-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*kdesu-4.6.5 (09 Jul 2011)
diff --git a/kde-base/kdesu/kdesu-4.7.0.ebuild b/kde-base/kdesu/kdesu-4.7.0.ebuild
new file mode 100644
index 000000000000..e181d758fe72
--- /dev/null
+++ b/kde-base/kdesu/kdesu-4.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/kdesu-4.7.0.ebuild,v 1.1 2011/07/27 14:04:27 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-runtime"
+inherit kde4-meta
+
+# FIXME: Is default command ( su/sudo ) still configurable,
+# if not, USE-flag ?
+DESCRIPTION="KDE: gui for su(1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+src_configure() {
+ # Upstream moved kdesu to libexec first, then decided to move it back
+ # to /${PREFIX}/bin/ , so I'm doing that now already.
+ sed -e '/kdesu_executable/s:LIBEXEC_INSTALL_DIR:BIN_INSTALL_DIR:' \
+ -i "${S}"/kdesu/kdesu/CMakeLists.txt || \
+ die "Moving kdesu from libexec to bin failed."
+
+ kde4-meta_src_configure
+}