summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdeprint/kdeprint-3.5.10.ebuild')
-rw-r--r--kde-base/kdeprint/kdeprint-3.5.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/kdeprint/kdeprint-3.5.10.ebuild b/kde-base/kdeprint/kdeprint-3.5.10.ebuild
new file mode 100644
index 000000000000..7bc0c23eef7e
--- /dev/null
+++ b/kde-base/kdeprint/kdeprint-3.5.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeprint/kdeprint-3.5.10.ebuild,v 1.1 2008/09/13 23:58:16 carlo Exp $
+
+KMNAME=kdebase
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE printer queue/device manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="cups kde kdehiddenvisibility"
+
+# TODO Makefile reads ppd models from /usr/share/cups/model (hardcoded !!)
+DEPEND="cups? ( net-print/cups )"
+RDEPEND="${DEPEND}
+ app-text/enscript
+ app-text/psutils
+ kde? ( || ( >=kde-base/kghostview-${PV}:${SLOT} >=kde-base/kdegraphics-${PV}:${SLOT} ) )"
+
+src_compile() {
+ myconf="$myconf $(use_with cups)"
+ kde-meta_src_compile
+}