summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ark/ark-4.8.1.ebuild')
-rw-r--r--kde-base/ark/ark-4.8.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-base/ark/ark-4.8.1.ebuild b/kde-base/ark/ark-4.8.1.ebuild
new file mode 100644
index 000000000000..0af731c343e8
--- /dev/null
+++ b/kde-base/ark/ark-4.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.8.1.ebuild,v 1.1 2012/03/06 23:35:11 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test
+# tests hang, no bug yet
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}