summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomeui/libgnomeui-2.24.0.ebuild')
-rw-r--r--gnome-base/libgnomeui/libgnomeui-2.24.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnome-base/libgnomeui/libgnomeui-2.24.0.ebuild b/gnome-base/libgnomeui/libgnomeui-2.24.0.ebuild
new file mode 100644
index 000000000000..35c5019d2b8e
--- /dev/null
+++ b/gnome-base/libgnomeui/libgnomeui-2.24.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeui/libgnomeui-2.24.0.ebuild,v 1.1 2008/09/28 05:19:26 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="User Interface routines for Gnome"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+# gtk+-2.14 dep instead of 2.12 ensures system doesn't loose VFS capabilities in GtkFilechooser
+RDEPEND=">=dev-libs/libxml2-2.4.20
+ >=gnome-base/libgnome-2.13.7
+ >=gnome-base/libgnomecanvas-2
+ >=gnome-base/libbonoboui-2.13.1
+ >=gnome-base/gconf-2
+ >=x11-libs/pango-1.1.2
+ >=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.14
+ >=gnome-base/gnome-vfs-2.7.3
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-keyring-0.4
+ >=dev-libs/popt-1.5"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+PDEPEND="x11-themes/gnome-icon-theme"
+
+DOCS="AUTHORS ChangeLog NEWS README"