summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild')
-rw-r--r--games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild b/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
index 537c82a222af..1526ebc3ddcf 100644
--- a/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
+++ b/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild,v 1.13 2006/02/07 03:45:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild,v 1.14 2006/02/27 20:56:09 mr_bones_ Exp $
inherit games cvs
@@ -10,9 +10,9 @@ HOMEPAGE="http://dosbox.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE="alsa opengl debug"
+IUSE="opengl debug"
-DEPEND="alsa? ( media-libs/alsa-lib )
+DEPEND="media-libs/alsa-lib
opengl? ( virtual/opengl )
>=media-libs/libsdl-1.2.0
sys-libs/zlib
@@ -27,18 +27,12 @@ ECVS_TOP_DIR=${DISTDIR}/cvs-src/${PN}
S=${WORKDIR}/${ECVS_MODULE}
src_compile() {
- local myconf
-
- if ! use alsa ; then
- myconf="--without-alsa-prefix --without-alsa-inc-prefix --disable-alsatest"
- fi
./autogen.sh || die "autogen.sh failed"
egamesconf \
--disable-dependency-tracking \
$(use_enable debug debug heavy) \
- ${myconf} \
$(use_enable opengl) \
- || die
+ || die
emake || die "emake failed"
}